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KB0264: TimeSafe Personaleinsatzplanung: Fehler in der Mitarbeiterplanung

Beschreibung

Der nachfolgend beschriebene Fehler tritt auf, wenn die TimeSafe Leistungserfassung auf die Version v.3.7 aktualisiert wurde und danach mit der Personaleinsatzplanung Version < v.1.1.3 gearbeitet wird. Der Fehler tritt nach dem Navigieren in die Mitarbeiterplanung auf. Dies nachdem entweder ein neuer Planungseintrag für den Mitarbeiter erstellt wird oder nachdem die Suche in der Mitarbeiterplanung ausgelöst wird.

Ursache

Der Typ von einigen Feldern der Tabelle mit den Projekten wurde in der Datenbank nach "ntext" geändert. Für das Anzeigen der Daten der Mitarbeiterplanung wird in der SQL-Abfrage das Schlüsselwort "DISTINCT" verwendet. Dies ist jedoch mit Spalten vom Typ "ntext" nicht möglich.

Lösung

Die nachfolgenden Aktionen müssen auf dem Webserver durchgeführt werden, auf dem die TimeSafe Personaleinsatzplanung installiert ist:

  1. Laden Sie die korrigierten Komponenten herunter und extrahieren Sie die Dateien in ein temporäres Verzeichnis.
  2. Navigieren Sie im Windows Explorer in das Installationsverzeichnis der TimeSafe Personaleinsatzplanung. Das Installationsverzeichnis befindet sich im Normalfall unter "c:\Inetpub\wwwroot\TimeSafePEP".
  3. Navigieren Sie im Windows Explorer in das Unterverzeichnis "bin".
  4. Kopireren Sie die beiden unter Punkt 1 extrahieren Dateien "Common.dll" und "DataLayer.dll" in das Unterverzeichnis "bin" und ersetzen Sie die bestehenden Dateien.

Dieser Fehler ist ab der Version v.1.1.3 der TimeSafe Personaleinsatzplanung korrigiert.

Kategorien: Anleitungen, Installation